re = /(?<=newProductsInfo: .*?)\[\d+].*?(?=,\[\d+]|$)/m
str = 'newProductsInfo: [[1] - $2 dollars,[2] New Product,[3] Hello,[4]Same, [5]Value]
newProductsInfo: [[1] - $2 dollars,[4]Same, [5]Value],[2] New Product,[3] Hello,[4]Same, [5]Value]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end