import Foundation
let pattern = #"\(\s*(.*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
node
( t-ur0wkjqky55s9mlh2rtt0u30r ) {
text ("[g:token.dice.Sum] roll the dice with (6)[v:token.dice.NumSides] sides (3)[v:token.dice.NumDice] times")
plan (Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA= )
}
node (t-vr0wkjqky55s9mlh2rtt0u301 ) {
text ("[g:token.dice.Sum] boll tha dice with (6)[v:token.dice.NumDice] side (3)[v:token.dice.NumSides] times" )
plan ( Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA=)
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)