using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"e\b";
string input = @"Some text to show this is matching words ending with ""e"". Bee-Bee: Bee! Bee? Bee; Bee
Bee\Bee/Bee and (Bee) but bee@bee.bee";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}