// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"e\b").unwrap();
let string = "Some text to show this is matching words ending with \"e\". Bee-Bee: Bee! Bee? Bee; Bee
Bee\\Bee/Bee and (Bee) but bee@bee.bee";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}