import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "e\\b";
final String string = "Some text to show this is matching words ending with \"e\". Bee-Bee: Bee! Bee? Bee; Bee\n"
+ "Bee\\Bee/Bee and (Bee) but bee@bee.bee";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}