package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)lorem[\s\S]*ipsum|ipsum[\s\S]lorem`)
var str = `Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}