const regex = /lorem[\s\S]*ipsum|ipsum[\s\S]lorem/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('lorem[\\s\\S]*ipsum|ipsum[\\s\\S]lorem', 'gi')
const str = `Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}