using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"</[^<>]*>\s*(\w+)";
string input = @"something something bar<TEST> blah blah </TEST> foo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}