re = /<\/[^<>]*>\s*(\w+)/m
str = 'something something bar<TEST> blah blah </TEST> foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end