$re = '/</[^<>]*>\s*(\w+)/m';
$str = 'something something bar<TEST> blah blah </TEST> foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);