using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\/]+?)\/(get\/.+)";
string input = @"http://localhost/akasia/may/be/lots/of/seperator/but/ineed/last/get/ships/for/rent/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}