$re = '/([^\/]+?)\/(get\/.+)/';
$str = 'http://localhost/akasia/may/be/lots/of/seperator/but/ineed/last/get/ships/for/rent/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);