package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\/]+?)\/(get\/.+)`)
var str = `http://localhost/akasia/may/be/lots/of/seperator/but/ineed/last/get/ships/for/rent/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}