# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n/ /gm;t' <<< "row 1
row 2
row 3
row 4
row 5
row 6
row 7"