$re = '/\n/m';
$str = 'row 1
row 2
row 3
row 4
row 5
row 6
row 7';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;