use strict;
my $str = 'row 1
row 2
row 3
row 4
row 5
row 6
row 7';
my $regex = qr/\n/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";