#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(==[^=]+==)(.+?(?=[^=]==[^=]|$))"
Local $sString = "== Paragraph == " & @CRLF & _
"=== title 1 ===" & @CRLF & _
"content" & @CRLF & _
"" & @CRLF & _
"=== Title 2 ===" & @CRLF & _
"other content " & @CRLF & _
"" & @CRLF & _
"== Paragraph 2 ==" & @CRLF & _
"=== asd1 ===" & @CRLF & _
"dfdsfdsfdsfdsfdsfsdfdsf" & @CRLF & _
"" & @CRLF & _
"=== asd2 ===" & @CRLF & _
"fgdfgfdgfdgfdgfdgfdgfdg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")