import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(==[^=]+==)(.+?(?=[^=]==[^=]|$))";
final String string = "== Paragraph == \n"
+ "=== title 1 ===\n"
+ "content\n\n"
+ "=== Title 2 ===\n"
+ "other content \n\n"
+ "== Paragraph 2 ==\n"
+ "=== asd1 ===\n"
+ "dfdsfdsfdsfdsfdsfsdfdsf\n\n"
+ "=== asd2 ===\n"
+ "fgdfgfdgfdgfdgfdgfdgfdg";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}