re = /(==[^=]+==)(.+?(?=[^=]==[^=]|$))/
str = '== Paragraph ==
=== title 1 ===
content
=== Title 2 ===
other content
== Paragraph 2 ==
=== asd1 ===
dfdsfdsfdsfdsfdsfsdfdsf
=== asd2 ===
fgdfgfdgfdgfdgfdgfdgfdg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end