#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d[\d\s]*(?:\s+[^\d\s]+)+"
Local $sString = "73000 PARIS 74000 LYON" & @CRLF & _
"75 000 MARSEILLE 68483 LILLE" & @CRLF & _
"60 MARSEILLE 68483 LILLE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")