package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d[\d\s]*(?:\s+[^\d\s]+)+`)
var str = `73000 PARIS 74000 LYON
75 000 MARSEILLE 68483 LILLE
60 MARSEILLE 68483 LILLE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}