$re = '/\b\d[\d\s]*(?:\s+[^\d\s]+)+/m';
$str = '73000 PARIS 74000 LYON
75 000 MARSEILLE 68483 LILLE
60 MARSEILLE 68483 LILLE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);