$re = '%<a[^>]*?~dead host~.*?</a>%i';
$str = '
<a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;