re = /<a[^>]*?~dead host~.*?<\/a>/i
str = '
<a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
<a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://stackoverflow.com\' rel=\'nofollow\' target=\'blank\'>part-2</a><a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a>
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result