using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\\|\/)(bye|end)$";
string substitution = @"";
string input = @"\bye";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}