use strict;
my $str = '\\bye';
my $regex = qr/^(\\|\/)(bye|end)$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";