package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d.*?) (.*)|(.*) (\d.*)|(.+)`)
var str = `Järvägstationg. 3/B
Überbrückerstraße 24a
Street Blah Blah 34
34 Street Blah Blah
Ueckerstr. 20 b
Elmshornerstraße 163
Hallgartenerstrasse Moritzstr.
19 Green Lane`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}