$re = '/^(\d.*?) (.*)|(.*) (\d.*)|(.+)/m';
$str = 'Järvägstationg. 3/B
Überbrückerstraße 24a
Street Blah Blah 34
34 Street Blah Blah
Ueckerstr. 20 b
Elmshornerstraße 163
Hallgartenerstrasse Moritzstr.
19 Green Lane';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);