// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d.*?) (.*)|(.*) (\d.*)|(.+)").unwrap();
let string = "Järvägstationg. 3/B
Überbrückerstraße 24a
Street Blah Blah 34
34 Street Blah Blah
Ueckerstr. 20 b
Elmshornerstraße 163
Hallgartenerstrasse Moritzstr.
19 Green Lane";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}