using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^vas\/(?<param>test)|(?<param>var\/test)";
string input = @"vas/test
var/test";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}