$re = '/^vas\/(?<param>test)|(?<param>var\/test)/Jim';
$str = 'vas/test
var/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);