package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^vas\/(?<param>test)|(?<param>var\/test)`)
var str = `vas/test
var/test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}