#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\[xxx\]\s*$[^\[]*^bbb=(.*)$"
Local $sString = "[zzz]" & @CRLF & _
"bbb=nee" & @CRLF & _
"[xxx]" & @CRLF & _
"aaa=nee" & @CRLF & _
"bbb=ok" & @CRLF & _
"ccc=nee"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")