import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[xxx\\]\\s*$[^\\[]*^bbb=(.*)$";
final String string = "[zzz]\n"
+ "bbb=nee\n"
+ "[xxx]\n"
+ "aaa=nee\n"
+ "bbb=ok\n"
+ "ccc=nee";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}