package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\[xxx\]\s*$[^\[]*^bbb=(.*)$`)
var str = `[zzz]
bbb=nee
[xxx]
aaa=nee
bbb=ok
ccc=nee`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}