#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\"DataType\",\"Count\"(.*?)\"DataType\",\"Net\""
Local $sString = ""Date","dd/mm/yyyy"" & @CRLF & _
""ExpirationDate","dd/mm/yyyy"" & @CRLF & _
"" & @CRLF & _
""DataType","Count"" & @CRLF & _
""Location","Unknown","Variable1","Variable2","Variable3"" & @CRLF & _
""A(Loc3, Loc4)","Unknown","5656","787","42"" & @CRLF & _
""A(Loc5, Loc6)","Unknown","25","878","921"" & @CRLF & _
"" & @CRLF & _
""DataType","Net"" & @CRLF & _
""Location","Unknown","Variable1","Variable2","Variable3"" & @CRLF & _
""A(Loc3, Loc4)","Unknown","5656","787","42"" & @CRLF & _
""A(Loc5, Loc6)","Unknown","25","878","921""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")