using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""DataType\"",\""Count\""(.*?)\""DataType\"",\""Net\""";
string input = @"""Date"",""dd/mm/yyyy""
""ExpirationDate"",""dd/mm/yyyy""
""DataType"",""Count""
""Location"",""Unknown"",""Variable1"",""Variable2"",""Variable3""
""A(Loc3, Loc4)"",""Unknown"",""5656"",""787"",""42""
""A(Loc5, Loc6)"",""Unknown"",""25"",""878"",""921""
""DataType"",""Net""
""Location"",""Unknown"",""Variable1"",""Variable2"",""Variable3""
""A(Loc3, Loc4)"",""Unknown"",""5656"",""787"",""42""
""A(Loc5, Loc6)"",""Unknown"",""25"",""878"",""921""";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}