# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"DataType\",\"Count\"(.*?)\"DataType\",\"Net\""
test_str = ("\"Date\",\"dd/mm/yyyy\"\n"
"\"ExpirationDate\",\"dd/mm/yyyy\"\n\n"
"\"DataType\",\"Count\"\n"
"\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"\n"
"\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"\n"
"\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"\n\n"
"\"DataType\",\"Net\"\n"
"\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"\n"
"\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"\n"
"\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.