#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(<tag2>.*?</tag2>)|<tag>(?:(?!<tag\s?>).)*" & @CRLF & _
""
Local $sString = "This <tag2>is a WORD</tag2> --- Match" & @CRLF & _
"<TAG><TAG2>xxx</TAG2></TAG> --- Not a match" & @CRLF & _
"<TAG>xxxxxxx<TAG2>yyyy</TAG2>xxxxxxx</TAG> --- Not a match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")