re = /(<tag2>.*?<\/tag2>)|<tag>(?:(?!<tag\s?>).)*
/mix
str = 'This <tag2>is a WORD</tag2> --- Match
<TAG><TAG2>xxx</TAG2></TAG> --- Not a match
<TAG>xxxxxxx<TAG2>yyyy</TAG2>xxxxxxx</TAG> --- Not a match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end