import re
regex = re.compile(r"""
(<tag2>.*?</tag2>)|<tag>(?:(?!<tag\s?>).)*
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("This <tag2>is a WORD</tag2> --- Match\n"
"<TAG><TAG2>xxx</TAG2></TAG> --- Not a match\n"
"<TAG>xxxxxxx<TAG2>yyyy</TAG2>xxxxxxx</TAG> --- Not a match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")