using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url=?\]([a-z0-9:\.\\\/\-\s]*?)\[\/url\]";
string input = @"[url]jg-76.\/ as78[/url]";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}