$re = '/\[url=?\]([a-z0-9:\.\\\\\/\-\s]*?)\[\/url\]/s';
$str = '[url]jg-76.\\/ as78[/url]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);