package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[url=?\]([a-z0-9:\.\\\/\-\s]*?)\[\/url\]`)
var str = `[url]jg-76.\/ as78[/url]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}