#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?P<Alternation1>" & @CRLF & _
" \$\{(?P<braced>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\w*)+)" & @CRLF & _
" \}" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (?P<Alternation2>" & @CRLF & _
" \$(?P<named>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\w*)+" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
""
Local $sString = "asdasd $asd:sd + ${asd123:asd} $HOME $$asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")