const regex = new RegExp('(?P<Alternation1>
\\$\\{(?P<braced>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\\w*)+)
\\}
)
|
(?P<Alternation2>
\\$(?P<named>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\\w*)+
)
)
', 'g')
const str = `asdasd \$asd:sd + \${asd123:asd} \$HOME \$\$asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}