re = /(?P<Alternation1>
\$\{(?P<braced>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\w*)+)
\}
)
|
(?P<Alternation2>
\$(?P<named>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z]\w*)+
)
)
/x
str = 'asdasd $asd:sd + ${asd123:asd} $HOME $$asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end