import re
regex = re.compile(r"(?:#|//)[^\r\n]*|/\*[\s\S]*?\*/")
test_str = ("mystring bla bla bla <-- should find this\n"
"bla bla mystring bla <-- also this\n"
"// bla bla mystring <-- not this , because is already commented\n"
"//mystring <-- not this\n"
"// alkdfjñas askfjña bla bla mystring <-- not this\n"
"wsfier mystring añljkfasñf <--should find this\n"
"mystring //a comment <-- should find this\n"
" bla bla // asfsdf mystring <-- should SKIP this, because mystring is commented\n"
"/* \n"
"asdfasf\n"
"mystring <-- i dont care if it finds this, even if it is inside a block comment\n"
"añfkjañsflk\n"
"// aksañl mystring <-- but should skip this, because the single line is already commented with '//' (regardless the block comment) \n\n"
"añskfjñas\n"
"asdasf\n"
"*/")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")