re = /(?:#|\/\/)[^\r\n]*|\/\*[\s\S]*?\*\//
str = 'mystring bla bla bla <-- should find this
bla bla mystring bla <-- also this
// bla bla mystring <-- not this , because is already commented
//mystring <-- not this
// alkdfjñas askfjña bla bla mystring <-- not this
wsfier mystring añljkfasñf <--should find this
mystring //a comment <-- should find this
bla bla // asfsdf mystring <-- should SKIP this, because mystring is commented
/*
asdfasf
mystring <-- i dont care if it finds this, even if it is inside a block comment
añfkjañsflk
// aksañl mystring <-- but should skip this, because the single line is already commented with \'//\' (regardless the block comment)
añskfjñas
asdasf
*/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end