using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*\#(region|endregion).*\n";
string input = @"
#region
SqlConnection con = new SqlConnection(strConnString);
SqlDataAdapter da = new SqlDataAdapter();
da.SelectCommand = new SqlCommand(""report_GetEuroRate"", con);
da.SelectCommand.CommandType = CommandType.StoredProcedure;
DataSet ds = new DataSet();
da.Fill(ds, ""EuroRateTbl"");
DataTable dt = ds.Tables[""EuroRateTbl""];
int count = dt.Rows.Count;
if (count > 0);
#endregion";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}